If you are running reports and are receiving FRM-41213 errors (Unable to connect to report server), there could be a possibility that your firewall could be blocking a port which the report server uses.
Create a rule to allow port 14021 in your firewall.
Run rwdiag.bat -findAll (Gives you port 14021 and the channel address)
Open port 14021
In the firewall, allow requests from your host IP address to the channel address found above.
Reference: See Oracle Support note 415407.1 for more information.